Global Mapper is GIS software that is more lightweight than ArcGIS but can do certain things more quickly or easily. This guide will cover some common uses of Global Mapper, and instructions are accurate for Global Mapper version 18.2 64-bit.

Carleton University students, faculty and staff are able to access Global Mapper remotely on the library's GIS workstations.

For more, Global Mapper provides extensive help documentation in their Knowledge Base (version 21.1).

  1. Add a basemap so you can see where things are
  2. Load a digital elevation model (DEM)
  3. Load a LiDAR file
  4. View DEM, LiDAR, or other 3D file in 3D
  5. Create an elevation profile graph from a 3D file (DEM, LiDAR, etc.)
  6. Clip a DEM or air photos (raster files)
  7. Save a shapefile as a DWG file
  8. Clip shapefiles or DWG files (vector files)

Add a basemap so you can see where things are

Adding a basemap means you can quickly load a map so you can figure out where things are, or zoom into your area of interest. It's often helpful, especially when working with geospatial datasets that cover a large area.

**Please note that many CAD datasets do not have a projection so will not overlay properly on a map.

  1. When you first open Global Mapper, you can click the Online Sources link. If you already have Global Mapper open and you're past the first screen, click File > Download Online Imagery/Topo/Terrain Maps...
  2. Select a source to download in the list. Our go-tos are OpenStreetMap.org Global Street Maps or World Street Map.
  3. Since the map data is coming from an online source, it may take a moment or two to load. You can then zoom in to your area of interest or load your own data.

Load a digital elevation model (DEM)

  1. When you first open Global Mapper, it will display four options: Open Data Files, Online Sources, Configuration, and Load Default Data. Click Open Data Files and browse to the file(s) you would like to add.
    • It is also possible to click and drag files into the Global Mapper window or click File > Open Data Files...
  2. Once the DEM file is loaded, the scale and elevation colour ramp (legend) will be visible. The colour ramp will adjust as you add/remove DEM files, if the minimum and maximum elevation change.

Load a LiDAR file

  1. As with loading a DEM file (above), select the option to Open Data Files and browse to the LiDAR (.las, .laz, .zlas) file(s) you wish to open
    • It is also possible to click and drag files into the Global Mapper window or click File > Open Data Files...
  2. You may be prompted to to select a projection. Generally, the default projection selected works. Click OK.
  3. A LiDAR Load Options dialog box will open. Again, the defaults generally function well.
    • Selecting a different symbology (color by classification or intensity, etc.) can be done in the Create Point Cloud option near the top of the dialog box
    • It is also possible to create an elevation grid and set parameters from this dialog box
  4. Depending on the size of the file(s), loading may take a few moments. As with DEMs, once the file is loaded the scale and elevation colour ramp (legend) will be visible. The colour ramp will adjust as you add/remove files if the minimum and maximum elevation change.

View a DEM, LiDAR, or other 3D file in 3D

  1. With a 3D file loaded, click on View > 3D View...

Create a 3D profile graph from a 3D file

The Path Profile tool used with a 3D dataset will generate an elevation profile (like a vertical slice of the landscape along a path) for a user-provided path.

  1. With a 3D file loaded, such as a DEM, click on Tools > Path Profile/LOS in the menu or click the Path Profile button in the toolbars

  2. To create a path, click on the 3D dataset and left-click to "connect the dots" to create a line of your choosing. Click the Esc key to start over.
  3. When you are satisfied with your line, right-click to generate the path profile
  4. In the Path Profile/Line of Sight dialog box, it is possible to save the graph, create a line of sight, and generate information about the path. Many more details for this tool are available in Global Mapper's user guide.

Clip a DEM or air photos (raster files)

Clipping a raster file (continuous surface comprised of pixels) is very straightforward in Global Mapper and can be helpful when an area of interest is either within a much larger tile or covers multiple tiles.

  1. Load all files (DEMs, air photos, etc.) required
  2. Go to File > Export in the menu
    • For elevation datasets like DEMs, select Export Elevation Grid format... from the list and then an appropriate filetype (using the same filetype as the original dataset is a good place to start - note that TIF files are under GeoTIFF)
    • For air photos, select Export Raster/Image Format... from the list and then an appropriate filetype (using the same filetype as the original dataset is a good place to start - note that TIF files are under GeoTIFF)
  3. When the export options dialog box appears, click on the Export Bounds tab
  4. Click the Draw a Box... button
  5. A new window will appear with the loaded data visible. Zoom in or out as appropriate using the zoom buttons, and click and drag to draw a box.

  6. When you are satisfied with the area selected, click OK then OK again.
  7. Browse to the location you'd like to save your file and give it a name. Click Save.

Save a shapefile as a DWG file

Watch this workflow in a video.

  1. Load the shapefile(s) required into Global Mapper by clicking File > Open Data Files... or clicking and dragging the .shp component in
  2. Click File > Export > Export to Vector/LiDAR format...
  3. In the Select Export Format dialog box, choose DWG and click OK
  4. The DWG Options tab has multiple possibilities for labels and DWG layer names; select as appropriate for your needs
    • You may want to ensure that Preserve Feature Attributes is checked off if you want to retain the attributes (e.g.: land use type)
  5. Click the Export Bounds tab to export All Loaded Data, or Draw a Box... to select your area of interest
  6. Click OK to browse to your saving location and name the file
    • Using a file name that tells you what is in the file, such as LandUseOttawa2010.dwg or CarletonRoadsParkingBuildings.dwg is recommended

Clip shapefiles or DWG files (vector files)

Clipping vector files (points, lines, or polygons) is straightforward in Global Mapper and can be helpful when an area of interest is within a much larger file.

  1. Load the file(s) required into Global Mapper by clicking File > Open Data Files...
  2. Click File > Export > Export to Vector/LiDAR format...
  3. In the Select Export Format dialog box, choose your filetype (Shapefile or DWG) and click OK
  4. For exporting to shapefile only, in the File Selection tab, select Export Areas, Export Lines, and/or Export Points. Browse to your saving location and name the file(s).
    • The available options will entirely depend on what kind of shapefiles (point, line, or polygon) you have loaded. If you have multiple types loaded, you can export those different types to separate files for the same clip boundary.
  5. Click the Export Bounds tab, then click the Draw a Box... button
  6. A new window will appear with the loaded data visible. Zoom in or out as appropriate using the zoom buttons, and click and drag to draw a box.

  7. When you are satisfied with the area selected, click OK then OK again.
Content last reviewed: