Converting Shapefiles to AutoCAD drawing files

All of the suggested softwares are available on the Library GIS workstations.

Overview: everything being equal, we recommend Global Mapper as overall it's the quickest and easiest way to export multiple shapefiles to one CAD file while also clipping to the area of interest. QGIS also exports multiple shapfiles to one CAD (DXF only) file while clipping to the viewing area and is the only Mac-compatible GIS software here. ArcMapArcGIS Pro, and FME Quick Translator export multiple shapefiles to one CAD file but don't clip to the area of interest during the export process.

Common errors when opening the DWG file in AutoCAD: When viewing the file in AutoCAD or other CAD software for the first time, you may get an error that essentially informs you that the file was not created in CAD software. That is fine - you still want to open it. You may also need to zoom to the extent if there doesn't seem to be any data in the CAD window.

Using ArcMap Desktop

  1. Ensure that the data you have is unzipped (e.g.: not in a zipped or compressed folder). You can unzip by right-clicking on the zipped folder and selecting Extract (or using a program like WinZip or 7-Zip).
  2. Open ArcMap. This was developed in ArcMap 10.7.
  3. Select all the files of type SHP and drag them into ArcMap
  4. Along the top of ArcMap, select 'Geoprocessing' then click on 'Search for tools'
  5. In the search bar, type "Export to CAD"
  6. Open the tool and then put all yourlayers as the input features
  7. Choose the output type (DWG_R2018 is the most up-to-date available)
  8. Choose an output file location, then click OK

Using ArcGIS Pro

  1. Ensure that the data you have is unzipped (e.g.: not in a zipped or compressed folder). You can unzip by right-clicking on the zipped folder and selecting Extract (or using a program like WinZip or 7-Zip).
  2. Open ArcGIS Pro and login (the process is here if it's the first time you've used ArcGIS Pro).
  3. Select all the files of type SHP and drag them into the Map window in ArcGIS Pro.
  4. Select the 'Analysis' ribbon
  5. Click on 'Tools'
  6. In the Geoprocessing panel that appears, search for 'Export to CAD'
  7. Click on the Export to CAD Conversion Tool in results
  8. Enter the input features (a.k.a. shapefiles) that you want to convert to CAD. Multiple shapefiles can be added.
  9. Select the output type (DWG 2018 is the most up-to-date available).
  10. In Output File, click the folder to browse to the location you want to save the CAD file. The default location is the ArcGIS Pro project folder and that's usually buried in a folder structure, so it's best to browse to where you want to save the CAD file.
  11. Click the Run button at the bottom of the Geoprocessing panel.

Using FME Quick Translator

  1. Ensure that the data you have is unzipped (e.g.: not in a zipped or compressed folder). You can unzip by right-clicking on the zipped folder and selecting Extract (or using a program like WinZip or 7-Zip).
  2. Open FME Quick Translator, which can be found on the desktop of the GIS workstations in the library.
  3. Under File, select Translate.
  4. Use the following parameters in the "Set Translation Parameters" dialog box:
    1. In the “Reader Format” use the drop down menu to select “Esri Shape”. If the option is not in the dropdown menu, just start typing it in and it will fill in the rest.
    2. In the “Reader Dataset” click on the “…” button to open a file directory and navigate to the .shp file.
    3. In the “WriterFormat” use the drop down menu to select “Autodesk AutoCAD DWG/DXF”. If the option is not in the dropdown menu, just start typing it in and it will fill in the rest.
    4. In the “Writer Dataset”, click on the “…” button to open a file directory and navigate to the location where you want the .dwg files to output to and give the file a name.
    5. Press OK once you're done to start the translation.
  5. Once FME is finished the translation it will say “Translation was SUCCESSFUL….Translation finished” . The newly created DWG file will be in the output folder you specified.
  6. Common errors when opening the DWG file in AutoCAD: When viewing the file in AutoCAD or other CAD software for the first time, beware that you may get an error that essentially informs you that the file was not created in CAD software. That is fine - you still want to open it. You may also need to zoom to the extent if there doesn't seem to be any data in the CAD window.

Using Global Mapper

Link to video of workflow.

  1. Ensure that the data you have is unzipped (e.g.: not in a zipped or compressed folder). You can unzip by right-clicking on the zipped folder and selecting Extract (or using a program like WinZip or 7-Zip).
  2. Open Global Mapper.
  3. Click Open Your Own Data Files and browse to the shapefile(s) you'd like to open (you can export multiple shapefiles to one CAD file)
  4. Click File > Export > Export Vector/Lidar format
  5. Select DWG in the Select Export Format dropdown, then click OK
  6. In the DWG Export Options dialog box, select your preferred DWG version and any other properties you'd like.
  7. Click OK
  8. Browse to where you'd like to save the file, name it, and click OK

Using QGIS

  1. Ensure that the data you have is unzipped (e.g.: not in a zipped or compressed folder). You can unzip by right-clicking on the zipped folder and selecting Extract (or using a program like WinZip or 7-Zip).
  2. Open QGIS. This workflow was developed in QGIS 3.10.
  3. Click Layer > Add Layer...> Add Vector Layer and browse to the shapefile(s) you'd like to open (you can export multiple shapefiles to one CAD file).
  4. Zoom in so that you can see only the data that you need. If you don't zoom in, all of the data will be exported.
  5. Click Project > Import/Export > Export Project to DXF...
  6. Browse to where you want to save the file, then check Export features intersecting the current map extent to only export what you see (refer to #4). Don't check this box if you want all of the data, but the file will be much larger.
  7. Click OK
Content last reviewed: January 28, 2021