Digital Elevation Model (DEM) Formats

DEMs are files that contain either points (vector) or pixels (raster), with each point or pixel having an elevation value. They come in a variety of file formats, from .csv to .dem to .txt, and you can derive lots of other information - like contours or 3D surface models - from them.

There are a few terms that may be encountered that have subtle but key differences:

  • DEMs: digital elevation models represent the land or "bare earth" (no trees, buildings, etc.)
  • DSMs: digital surface models represent the reflective surface of the earth (bare earth plus trees, buildings)
  • DTMs: digital terrain models are either synonymous with DEMs or comprised of a network of vector points instead of a continuous raster
  • Further details here and here

Is the file format you have not listed here? Contact us and/or consult lists of all raster and DEM file formats supported by ArcGISGlobal Mapper, and QGIS.

This information is accurate for ArcMap Desktop 10.6, ArcGIS Pro 2.1.3, Global Mapper 18, and QGIS 3.2.1.

GeoTIFF (.tif) | USGS DEM (.dem) | Floating Point Raster File (.flt) | ASCII Grid (.txt) | Comma-separated Values (.csv or .txt) | HGT (.hgt) | Grid (.grd) | NetCDF (.nc)


GeoTIFF

GeoTIFF files are already images, like .tif files but with geospatial information attached

GeoTIFFs allow location information to be embedded within a TIFF file. The following data authors use the GeoTIFF format:

How to Open

  1. Global Mapper: File > Open Data File(s)... and select the appropriate .tif file
  2. ArcMap: File > Add Data... and select the appropriate .tif file
  3. ArcGIS Pro: Add Data > Data and select the appropriate .tif file
  4. QGIS: Layer > Add Layer > Add Raster Layer... and select the appropriate .tif file

 

USGS DEM (.dem)

Several columns of data are processed by GIS software to create image of earth's surface

United States Geological Survey (USGS) DEM format is an open standard for raster-based DEMs. The following data authors use the .dem format:

How to Open

  1. Global Mapper: File > Open Data File(s)... and select the appropriate .dem file
  2. ArcMap: In ArcToolbox, go to Conversion Tools > To Raster > DEM to Raster
  3. ArcGIS Pro: In the Geoprocessing pane, go to Conversion Tools > To Raster > DEM to Raster
  4. QGIS: while GDAL library supports USGS DEMs, not functional in QGIS 2.18.13 (see Note) and does not appear to be functional in QGIS 3.2.1.

 

Floating Point Raster File (.flt)

A floating file and header file are both required by GIS software to produce an image

Floating point raster files include a binary floating-point file (.flt) and an ASCII header file (.hdr). Both need to be in the same directory/folder. The following data authors use the floating point raster file format:

How to Open

  1. Global Mapper: File > Open Data File(s)... and select the appropriate .flt file
  2. ArcMap: In ArcToolbox, go to Conversion Tools > To Raster > Float to Raster
  3. ArcGIS Pro: In the Geoprocessing pane, go to Conversion Tools > To Raster > Float to Raster
  4. QGIS: Layer > Add Layer > Add Raster Layer... and select the appropriate .flt file

 

ASCII Grid (.txt)

The ASCII file has a built-in header and then lines of data which is converted to an image by GIS software

ASCII grids are both human readable and hardware independent. It is a widely supported format that is easy to import and export from most GIS software, easy to convert with a small script if necessary, and stores data in a reasonably compact raster format when compressed. The following data author uses the ASCII grid format:

How to Open

  1. Global Mapper: File > Open Data File(s)... and select the appropriate .txt file
  2. ArcMap: In ArcToolbox, go to Conversion Tools > To Raster > Ascii to Raster
  3. ArcGIS Pro: Incompatible format without data manipulation or paid add-on toolbars. We recommend using another software.
  4. QGIS: Layer > Add Layer > Add Raster Layer... and select the appropriate .txt file

 

Comma-separated file (.txt, .csv)

Data values separated by commas (each row is one pixel) becomes an image of the surface in GIS software

Comma-separated files contain latitude, longitude and elevation information in a text file, with each data category (or "column") separated by a comma. The following data author uses the comma-separated format:

How to Open

  • Global Mapper: File > Open Data File(s)... and select the appropriate .txt file. Make sure to select Elevation Grid from 3D Point Data.
  • ArcMap: Add the data. Right click on the data file > Display X, Y Data...
  • ArcGIS Pro: Add the data. Right click on the data file > Display XY Data...
  • QGIS: Layer > Add Layer > Add Delimited Text Layer... and select the appropriate file. In the Geometry Definition portion, select Point coordinates and assign X and Y fields.

 

HGT (.hgt)

HGT files contain integers that give the height of each cell in the grid, generally arranged from west to east and north to south. More information. The following data author uses the HGT format:

How to Open

  • Global Mapper: File > Open Data File(s)... and select the appropriate .hgt file
  • ArcMap: File > Add Data... and select the appropriate .hgt file
  • ArcGIS Pro: File > Add Data... and select the appropriate .hgt file
  • QGIS: Layer > Add Layer > Add Raster Layer... and select the appropriate .hgt file

 

Grid (.grd)

Grid (.grd) files contain integers that give the height of each cell in the grid, generally arranged from west to east and north to south. Like shapefiles, grid files generally include several file components such as .grd, .gri, and .vrt files. The following data author uses the grid format:

How to Open

  • Global Mapper: File > Open Data File(s)... and select the appropriate .grd file
  • ArcMap: File > Add Data... and select the appropriate .vrt file
  • ArcGIS Pro: File > Add Data... and select the appropriate .vrt file
  • QGIS: Layer > Add Layer > Add Raster Layer... and select the appropriate .vrt file

 

NetCDF (.nc)

NetCDF (.nc), or Network Common Data Form, "is a set of software libraries and machine-independent data formats that support the creation, access, and sharing of array-oriented scientific data. It is also a community standard for sharing scientific data." (Source) The following data author uses the NetCDF format:

How to Open

  • Global Mapper: File > Open Data File(s)... and select the appropriate .nc file. 
  • ArcMap: 
    • ‚ÄčIn the Geoprocessing menu, click ArcToolbox
    • In the Toolbox window, scroll down and click to open Multidimension Tools
    • Select Make NetCDF Raster Layer
    • For Input netCDF file, browse to the .nc file you wish to open
    • Once it's selected, wait for the variables/attributes to load and fill in the remaining properties
    • Select the variable you wish to view, and ensure the X dimension and Y dimension are appropriate (longitude & latitude, x coordinate and y coordinate, etc.)
    • Click OK
    • To save the resulting grid as a raster, right-click on the raster that was created then click Data > Export Data...
  • ArcGIS Pro: 
    • Under the Analysis tab, select Tools
    • Click Toolboxes in the Geoprocessing window
    • Scroll down and click to open Multidimension Tools
    • Select Make NetCDF Raster Layer
    • For Input netCDF file, browse to the .nc file you wish to open
    • Once it's selected, wait for the variables/attributes to load and fill in the remaining properties
    • Select the variable you wish to view, and ensure the X dimension and Y dimension are appropriate (longitude & latitude, x coordinate and y coordinate, etc.)
    • Click Run
    • To save the resulting grid as a raster, right-click on the raster that was created then click Data > Export Raster
  • QGIS: Plugin required: https://plugins.qgis.org/plugins/tags/netcdf/
Content last reviewed: July 29, 2020